Lyve Cloud User Guide 
Lyve Cloud User Guide 

Was this content helpful?

Getting Started

Roles and Types (Account Identities)

There are three distinct roles for those who access the Lyve Cloud system:

RoleDescription
AdminCan manage users and policies, with the exception of the root account. A user identity will be assigned administrative rights.
RootThe initial and main identity of the customer account. Direct customer root identities can also create access/secret key pairs for access.

The root identity is assigned to the owner of the Lyve Cloud Space account. The root identity creates users and has the ability to assume the role of any underlying account. In a reseller account, the root identity can also assume the role of accounts allocated below it either automatically or by manually allowing access. This is a feature to assist in debugging subaccount issues. This identity or account cannot be deleted.
UserCan perform operations on buckets according to the policies that are attached. A user can change their own password and create access/secret key pairs for access. Reseller accounts do not allow creation or use of keys.

If you are configuring an application that needs to create buckets, there are two options for permissions:

  1. Provide sufficient credentials so that the application can create buckets when needed. For example, backup applications must be able to create directories to manage data structures when writing to S3 storage.
  2. Create a user that has admin privileges and allow that user to perform Read, Write, List and Delete operations on 'All Buckets' through a specified policy. See Create Policies.

Login Attempt Rate Limits

Any user with the appropriate credentials can log in to the Lyve Cloud service using the Web GUI.

As a security measure, rate limits on failed login attempts are applied. After four failed login attempts, the rate limit locks an account. A failed login attempt happens when any information provided during the login was incorrect. A locked account will not be allowed to log in for 5 minutes following the last failed login attempt, where the rate limit occurred.