Was this content helpful?
How could we make this article more helpful?
There are three distinct roles for those who access the Lyve Cloud system:
| Role | Description |
|---|---|
| Admin | Can manage users and policies, with the exception of the root account. A user identity will be assigned administrative rights. |
| Root | The initial and main identity of the customer account. Direct customer root identities can also create access/secret key pairs for access. The root identity is assigned to the owner of the Lyve Cloud Space account. The root identity creates users and has the ability to assume the role of any underlying account. In a reseller account, the root identity can also assume the role of accounts allocated below it either automatically or by manually allowing access. This is a feature to assist in debugging subaccount issues. This identity or account cannot be deleted. |
| User | Can perform operations on buckets according to the policies that are attached. A user can change their own password and create access/secret key pairs for access. Reseller accounts do not allow creation or use of keys. |
If you are configuring an application that needs to create buckets, there are two options for permissions:
Any user with the appropriate credentials can log in to the Lyve Cloud service using the Web GUI.
As a security measure, rate limits on failed login attempts are applied. After four failed login attempts, the rate limit locks an account. A failed login attempt happens when any information provided during the login was incorrect. A locked account will not be allowed to log in for 5 minutes following the last failed login attempt, where the rate limit occurred.